Interesting…will run this maximized for a bit, see if that changes anything.

Seem to be a few people with the same problem. I’m a bit surprised that nobody from NV has popped in with suggestions yet.

I found that the power setting for the network card was allowing it to be shut down. I changed that to always on, to match the other power settings for hard drives, etc.

The users said that it “might” be a bit better. Weren’t sure, but overall, still had a considerable wait.

We have found a workaround for the Excel issue. Save any Excel file (even a blank one) on your desktop. When Excel crashes, give it a double click, and if you’re as lucky as we’ve been, you’ll be back in business. It shows up in the taskbar again, with the open files sitting there waiting.