Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #11351

    I have a client with a DOS Based version of New Views (NV1) – things have been trouble free for some time. This week on opening the books the following error appeared:

    datad.nv – has wrong size

    I have recovered the files from a backup, same error? Any suggestions on what we can try?



    Hmm, sounds like you backed up the books while they were open?
    Rare, but possible !

    A simple REORG should take care of the “size” problem.


    Post Edited (02-01-05 19:53)


    The error message indicates that the size of the datad.nv file does not agree with the internal file size marker.

    The datad.nv file was not open when backed up. If the books where open when you had tried to back them up you would have received an error message along the lines “DATAD.NV access denied” or in use by another process.

    Run check books on the books (from the NewViews shell) and if result is reorganization is necessary then Reorganze the books. If the result is Heap Overflow or “Ram Buffer locked while Freeing”, then the books must come in for data recovery.

    Note: When you run check books, pay attention to the number of accounts. If the number of accounts encountered does not match the number of accounts on file then reorganization is possible but the end result may be messy.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.