Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #11740

    Dear Martin

    1. Could you let me know what printer codes I can use for the Ascii characters which will give me solid lines when I print to a file and then open that file in MS Word. At present the Ascii printer works but gives me broken lines in MS Word.

    2. How do I avoid the printing code on the first line when I import the printed file in MS Word.

    All other codes like Epson, HP etc gives me garbage

    Goolam Kolia
    South Africa


    This is the way I have been doing it.

    Make a copy of the hp printer code to a new printer definition

    Remove the code in the setup field

    Print to a file

    Open the file with word

    Select MS- DOS at the file conversion prompt

    Remove left, right ,top and bottom margins


    select all

    change the font to “courier new” and change the character size so the lines will not wrap

    This has worked for me with office 2003

    Good luck




    The suggestion Thomas has decribed is a good one. A variation would be do do what Thomas has suggested but use NOFORM as the printer for file output and then open in Word and then format the document. NOFORM does not include lines or under lines.

    Regards to All,



    Hi Martin and Thomas.

    A bit belated to thank you all, but wow your suggestions work great. I really appreciate it.

    Now to tax your brains and test your skills a bit more.
    You know the saying “newviews can do anything, it’s left to your imagination”

    Can you automate your printing process from Newviews to MSword.

    e.g. 1. Newviews print to a .bat or .exe file and with an icon on the desktop we can activate this file to print via a windows program to usb.
    e.g. 2. Newviews print to a file and call up MSword automatically and then via a macro in MSword call up that file and do the whole process (as you explained) and print automatically.



    Hi Goolam

    The first example I do not think it can be done.

    Second example.

    Do a search on your computer for winword.exe.
    Right click on it and drag to your desktop.
    Select create shortcut.
    right click on shortcut and click on properties.
    In the properties window that opens, click on the shortcut tab.
    In the target field it will look like this
    “C:Program FilesMicrosoft OfficeOFFICE11WINWORD.EXE”
    After the last quotation mark type the name of the file that you want to load in winword with the complete path like this.

    “C:Program FilesMicrosoft OfficeOFFICE11WINWORD.EXE” c:nvinvoice.txt

    now click on save

    From inside newviews set the print options to column 80
    and the file name to the file that you set in the shortcut including the path such as c:nvinvoice.txt

    A problem is that every time you print to a file newviews sets append to yes and you would be adding to the file every time you print.

    You can write a proc that will reset append to no and set the proc an fkey.
    Press the fkey before you print.
    You could also include in the proc a command such as ~PD to print document or call the invoice printing procedure.

    You will have to watch how many charecters you have in each line as WORD will linewrap if the line is too long you can also set the default font in word to a smaller font.

    Good luck



    Hi Thomas you’re a star.
    Your suggestion works great.
    Sometimes what seems to be very complicated has the simplest solution. Thanks to the Forum.
    I have tweaked your solution.
    I am using Wordpad which comes standard with Windows XP.
    I created a standard file output in Newviews and linked it to Wordpad shorcut icon on the desktop.
    When I print from Newviews, I then click on the desktop shorcut icon Wordpad and wow I have a screen preview of my document.
    I can then modify the document and then have the option to save, print to a usb printer or email.
    It also saves paper and ink and takes a few seconds.

    Many thanks
    Goolam Kolia
    South Africa

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.