Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #11538

    Hi –

    I recently moved NV1 Vers 1.40 to a new laptop running w/xp. Things seems to be fine except if I try to print a block of entries with / Print Block the whole program freezes. I’ve tried sending other things to the printer (from another program) and they print fine, so the NV print job wasn’t waiting for something behind it to ‘nudge’ it.

    The printer is a Canon MP 730 attached to another computer (also running xp) on a home wireless network.

    Same thing happens if I try a Proc such as PrtNon0. Screen and program lock and I need to abort.

    I suppose I could direct attach a printer to this laptop, but if anyone has any other ideas, I would appreciate hearing.

    Thanks – Meg


    I guess I’ve answered my own question by reading some old posts. I have since installed nvPRNq and am able to print just fine. Thanks to David.



    “I’ve tried sending other things to the printer (from another program) and they print fine …”

    I’m assuming those are Windows programs.

    Configuring a system to support printing from DOS programs can be a bit tricky, but here goes.

    1. The printer must support DOS printing – and this is getting to be a long-shot. Most new printers, especially ink-jet, do not support DOS printing. Asking a salesperson at a store, or even a support-rep for a printer manufacturer about this capability is usually a waste of time – most don’t know or really care if they answer the question correctly.

    Assuming the printer does support DOS printing, you are on to step 2.

    2. You can usually configure a Win 2K/XP system to support DOS printing by doing this:

    – In the properties of the printer you wish to print to, note the “Share” name. If it isn’t shared, enable sharing.

    – Note the name of the system the printer is connected to.

    – Get to an MS-Dos/Command prompt.

    Type: NET USE LPT1 \computernamesharename /PERSISTENT:YES

    (Substitute the correct names for the computename & sharename)

    If you get an error, try the same command but substitute LPT2 for LPT1.

    If you get through this command without an error, type: DIR > LPT1 [Enter]
    (Or LPT2, if that is what worked above.)

    This will send text output to the printer. If it prints, you are in business. If it doesn’t then either the printer doesn’t support DOS printing, or there is some other bug-a-boo at work. Note: Until you can get output from the printer doing DIR > LPT1 (or LPT2) then you won’t be able to print from NewViews (or any other DOS program.) That DIR command is the acid test.

    Assuming it worked, then in NewViews put LPT1 (or LPT2) in the FIle Name field of /Print Options and you’re good to go.


    P.S. Contrary to prevalant mythology, this can work on a system where the printer is connected via USB.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.